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Elementary School Start-Up Checklist 

School Details 
 Review School details  

Did the administration change? 
School Top Tab > Setup Side Tab   

o Click Details 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

o On Top Right corner, choose All fields as dropdown. Scroll to bottom 
and ensure Principal Email is correct.  

 
Ensure you make any admin/school detail changes on the Ministry’s EDX website 
Login to EDX here. 
 
 

Commit the Master Schedule 
        This process can take several minutes to complete! 

• Build View > Scenario TT – put a check beside the “copy of 2023-2024 Active Schedule”. 

This is the name of the scenario. 

• Click Details ST 

• Ensure the name of the scenario appears under the name of the school. 

•  

  

https://www2.gov.bc.ca/gov/content/education-training/k-12/administration/program-management/data-collections/education-data-exchange-engagement
https://educationdataexchange.gov.bc.ca/login
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• Click Terms ST. Here, the Start Date and End Date for each scheduled term should be 

defined. Click on FY schedule term and click Set Date to enter start and end date. If this 

step is missed, you will not be able to continue.  

• Click Save. 

• Click Details ST again.  

• Go into Options > Commit Schedule 

• In the pop-up, select Replace the active schedule. Click OK 

 

Set Active Schedule 

Schools require an active schedule to create schedule terms. Since, the schedule was committed 

from the Build view, the Active Schedule will already be set.  

To confirm an Active Schedule: 

• School View > School TT > Setup > Preferences > Category: Schedule 

Category is a drop down on the top right of the screen 

o Ensure the schedule mode field is set to “secondary”. Don’t change it. It is set to 

be secondary regardless of the school type. 

• School View > School TT > Schedules ST > Filter: Active Schedule 

When an Active schedule is set, there will be a small black triangle next to the active 

schedule, like this: 

 
o Your screen should show current school year (2024-2025) as the active 

schedule. 

o If the 2024-2025 Active Schedule does not have a triangle indicator, click into 

the record of the Active Schedule, Click Options > Set Active Schedule. 

o If the 2024-2025 Active schedule is not visible, then filter : All Records to find it 

and set it as Active Schedule as explained in the step above.  
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Add Courses Grade Term 
 School View > Grades TT > Grade Terms ST  

o Options > Add 

o Add Term ID using the Magnifying glass 

o Add Start Date and End Date 

School Calendar 
 Review School Calendar 

School Top Tab > Calendars Side Tab > Dates Sub Side Tab 
o Adjust non-session dates as necessary as some district school days must 

be left ‘in session’ to accommodate CE and the Kanaka Calendar 
If not already done, assign Day Numbers to each school day in session: 

o Use the Filter   Days In Session to display school days 
o Options > Mass Update 

 
 
 
 
 
 
  

o Click Update 

Student Information 
 Review Student Enrollment 

Ensure there are no students with a Pre-Reg Enrollment Status 

o Student Top Tab > Filter  - PreReg Students 
Do your Enrollment numbers match the Current Members (students in 

attendance) Filter ? 
o If not, compare the data in the filter with your own information using V 

Lookup 

Does the Current Members Filter match the All Active Students (active 

anywhere in BC) Filter ? Current Members and All Active Students should 
match 

o If not, compare the data from the two filters using V Lookup 
Once you find the student(s) in question, check their Membership details 

o Student Top Tab > Membership Side Tab 
o Correct as necessary 

If you need to change a student’s Enrollment Status 
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o Student Top Tab > Select the student 
o Options > Registration > Change Student Status 

 
Review Student Demographics 

Ensure every student has Calendar, Citizenship Code, Proof of Age, Home 
Language, Correct Address, Home Phone number, Correct Contacts 

 
YOG 

Are all students in the appropriate grade?  If not, then you will need to change the 
YOG (Year of Grad) to reflect the appropriate grade 
 
If you need to change YOG  

o Student Top Tab > Select the student  
o Options > Registration > Promote/Demote Student 

 
Homeschooler 

Do you have any Homeschooler’s registered with your school?  If so, their 
GrSubLvl (Grade Sub Level) needs to be HS.  Add an inclusion to the student’s PSR 
if you have a student who is being Homeschooled.  Please advise 
myedbchelpdesk@sd42.ca of any Homeschoolers. 
 
Are any students that were previously homeschooled and registered with your 
school now attending your school as a regular student?  If so, remove the Grade 
Sub Level of HS. 

 

Staff Information 
 Review Staff information 

Staff Changes 
If the school staff has changed DO NOT make any additions or deletions to 
the staff records in MyEdBC and do not make them inactive.  Staff must be 
assigned to schools by the MyEd Team.  Submit an IT Web HelpDesk ticket 
with full name of Teacher, FTE and start date. 
 

Assigning Homerooms 
Now that EOYR has completed, you can now change teacher divisions, if 
they’ve changed from last year.  If they haven’t, they’ll have rolled over 
with the same divisions from last year. 
 
To remain consistent across the district, remember the appropriate naming 
convention of the divisions of “DIV.XXX” whereby you use a minimum of 2 
numbers and up to 3 numbers.  Example:  DIV.01, DIV.10, DIV.001, DIV.101. 
Note the capitalization of DIV and there is no space between the period (.) 
and the number. 

mailto:myedbchelpdesk@sd42.ca
https://www.sd42.ca/helpdesk/helpdesk-create-ticket/
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Staff Top Tab 

o Options > Modify list and click on the pencil  in the Homeroom 

column (don’t forget to click on the  to save the changes to the 
column 

o Alternatively, Staff Top Tab > Select Staff > Details  
 

 
 
 
 
Assigning the appropriate teaching staff to the Attendance blocks 

o Once you have assigned the staff their divisions, don’t forget to adjust all 
the teaching staff of the Attendance Blocks in the schedule 

o Schedule TT 
o Click into the attendance block. If a change is necessary, click on the 

 beside the teacher name, Save, then use the  to choose the 
new teacher. 

o Don’t forget any co-teachers or Prep teachers in the ‘teachers’ sub-
side tab. You can now add teacher(s) as co-teacher to Multiple 
Course(s). School View > Schedule TT > Options > BC Multi-Add Co-
Teacher(s) to Section(s) 

 
Counsellors & Support Teacher staff 

Tickets will need to be created for each of the school’s teaching staff that 
are Support teachers and the school counsellor so that additional Security 
Roles are added to their staff record.  

 
Homerooms  

Student Top Tab > Filter   Current Members > Field set  Pre-Transition   
 

If you set the NextHomeroom before you left for summer vacation, then through 
EOYR the NextHomeroom became this year’s Homeroom 

 
If you left the NextHomeroom blank, then the Homeroom column you are 
looking at now is last year’s homerooms 

 
You will want to clarify, regardless, the student’s homerooms 

 
Update student homerooms as necessary 

o Cherry pick students 
o Options > Show selected  
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o Options > Mass Update 
Update the Homeroom field with this year’s homeroom 

Type the Value exactly as entered in Staff details (DIV.XX, for 
example) 
 
 
 
 
 

 

Adding Students into Attendance Sections 
Ensure students have been assigned a homeroom 
 
If you have ‘old’snapshots from the previous school year, delete them first 

o Student Top Tab  
o Options > Snapshots  

Choose the old snapshots from the previous school year and delete 
them (one at a time because it’s a radio button list) 
 

Create new snapshots of each division once the majority of student homeroom 
changes have been completed.   

o Student Top Tab  

o Filter  for each homeroom using Homeroom = ?  Enter one division at a 
time.  This will return to you all the students in DIV.01 (for example) only. 

o Select all students in the Division you’ve filtered for  
o Options > Snapshots 
o Click New  
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o Name the new snapshot  
 
Do Not check the box to Save as 
Filter 
 

o click Save 
 
 
 
 
 
 
 
 
 
 
 

Now you are ready to add students to Attendance sections 
o Schedule Top Tab 
o Select the first attendance section you wish to add students  
o Click Roster Sub Side Tab 
 

 
 
 
 
 
 

o Options > Add   
o Change Schedule Mode to Push 
o Students – Select Snapshots 
o Another Window opens – Select Division 
o OK 
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o  
 
 
 
 

o Add to the following sections: 
o Select 
o Choose both the AM and PM attendance blocks 

 
 
 
 
 
 
 
 

o OK 

Adding Students into Programs 
 Ensure that you have students added to correct 1701 fundable programs. 

• Do you have new AbEd students?  Advise Admin Secretary for Aboriginal Education 

Department and they will add Aboriginal – Other Approved Program to the student 

record. 

• Grades 5 6 and 7 will need to have the “Core French”, code #11002 program added 

unless they are French Immersion. If split Grade 4/5 class, check with Teacher if Grade 4 

students should receive Core French program as well 

• Kindergarten and any new registrants into French Immersion classes will need program 

code #11000, Early French Immersion added 

• Late French Immersion students (Golden Ears Elementary only) to have the program 

code #11001, Late French Immersion added 
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 If you have new students to the school and they have open programs from their previous 

school, please click into the prior programs and end date them with the date the student left the 

previous school. 

Photographer Export: 
You will likely have your student photo date already arranged for some time early in September 
or October.  Ensure that you do not provide the photographer with any more student 
information than they need.  Follow these steps to easily extract the information they need: 

• Student Top Tab > Filter  - Current Members > Field Set  - Photographer 

• Using the quick print option , choose CSV 

• Once the operation has run, open the CSV, rename it and save it to OneDrive 

• Follow this process to share the document to the Photographer: 

To password protect a folder or document to be shared with external users, click on the 

OneDrive (Blue Cloud) icon in your task bar and then choose View online 

 

Select the file or folder you want to share and then click on the Share icon  

 

Choose Anyone with the link option and then set a unique password (not one you currently 

use for anything else).  You can also specify when access to the file or folder will stop 
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Public Health Nurses 
Extracts are provided to Fraser Health directly from Board Office for all Kindergarten, grade 6 and grade 
9 students.  If you are asked to send them data via an excel document, please ask them to contact 
MyEdBCHelpdesk@SD42.ca 

 

Transferring K’s to new Schools 
If there are kindergarten students that are transferring to new schools in district prior to the first day of 
school, follow the transfer process.  The incoming school must set the withdraw reason from the 
previous school to no show since the student never attended the exiting school.  This will ensure the 
membership record is correct. 
 
If there are kindergarten students that are leaving the school for an out of district school prior to the 
first day of the school year, then withdraw the student with a reason of no show since the student 
never attended the exiting school.  This will ensure the membership record is correct. 

mailto:MyEdBCHelpdesk@SD42.ca

