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Index 
Please click on the topics, to jump directly to their relevant section: 

Verify School Settings 

Review Attendance Settings 

Commit the Schedule (Task for VP/Admin) 

Set Active Schedule (Task for VP/Admin) 

Verify Bell Schedule 

Assigning Bell Schedules to Calendar Dates  

School Calendar Setup  

Modify School Calendar 

 Review School Structure  

Setup Grade Terms (Task for VP/ Admin) 
 
Setup Grade Term Cover Maps (Task for VP/Admin) 
 
Review Course Catalogue 
 
Review Rooms 
 
Review Schedule settings 
 
Assigning Schedule Days to your Calendar 
 
Review Student Schedule 
 
Verify Student Demographics  
 
Verify and update locker information (School)  
 
Review student locker                  assignments  
 
Review Student  Information  
 
Review Student Enrollment  
 
Adding Students into Programs 
 
Students with Secondary  School Associations 
 
Review Fee Assignments 
 
Validate Staff Records 
 
Staff Changes 
 
Assigning Homerooms to Teachers 
 
Assigning Homerooms to Students 
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TASK PATH DESCRIPTION RELEVANT 
DOCUMENTS 

Verify School 
Settings 

School View > School 
TT > Setup > Details 

1. On the General sub-tab, ensure 
accuracy of the information in the 
following fields – no change 
should be required. Do not 
change any other settings… 

2. Click the Address sub-tab and 
ensure the school’s address 
information is accurate 

School Setup 

Review 
Attendance 
Settings 

School View > School 
TT > Setup > 
Preferences 

1. Category = Daily Attendance 
2. Category = Class Attendance 
3. Category = Secondary School 

Management 

1. School Setup 
2. Class 

Attendance 
Management 

3. Daily 
Attendance 
Management 

Commit the 
Schedule 
(Task for 
VP/Admin) 

Build View > Scenario 

1. Ensure term record has a date 
range set 
By clicking Terms ST > Set Dates 

2. Click the record for the current year 
schedule. Option > Commit 
Schedule 

3. Review Master Schedule in School 
View (Section details) 

School Setup 

Set Active 
Schedule 
(Task for 
VP/Admin) 

School view > School 
TT> Schedules ST 

1. If a schedule was committed from 
the Build View, this will be in place. 

2. If creating schedules manually, an 
active schedule will need to be 
created. 

3. Select the Filter option and choose 
ALL RECORDS to determine if a 
school  
schedule exists for your school. 

4. If a schedule record exists, click on 
the link for the record for the current 
school year to display the record. 

5. Click Option > Set Active 
Schedule 

6. IF no schedule exists for your 
school: 
a. Click Options > Add. 
b. Populate the Name field with the 
current schedule name. Example: 
2023-2024. 
c. Use the icon to select a Start 
Date. 
d. Use the icon to select an End 
Date. 
e. Click Save. 
f. Click Options > Set Active 
Schedule. 

School Setup 
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7. Check your work: A triangle will 
appear beside the active schedule 

Verify Bell 
Schedule 

School View > 
Structure > Bell 
Schedule 

Verify Bell schedule is in place.  
Bell Schedules can be copied forward 
from last year by doing the following: 
1. Schedule> Structure> Bell 
Schedule 
2. Options > Copy From 
3. Choose the School Year and the 
Active Schedule 
To Create a new Bell schedule: 
Schedule >Structure >Bell 
Schedules> Options> Add 
1. Type a unique Identifier, Name, and 
Description for the bell schedule. 
2. The ‘Include in scheduling?’ 
checkbox, is functionality that will be 
used by the build  
engine. During initial setup there are no 
implications of setting this box either 
way. 
3. For each period, define the Start time 
and Duration (Minutes). 
4. To add an additional period for an 
after-school program, or another extra 
period not in the academic schedule, 
click Add. The Add Bell Period dialog 
box appears. Define the  
Bell period number, Period name, Start 
time and Duration (Minutes), and click 
OK. 
5. Click Save. 

School Setup 

Assigning 
Bell 
Schedules to 
Calendar 
Dates 

School View > School 
TT > Calendars > 
Dates leaf 

Option 1: Update multiple records at 
once. 

• Select multiple dates for which you 
want to assign the same bell 
schedule 

•  Click Options in the menu bar, then 
choose Show Selected. It is 
important that the screen now 
displays only the dates to which you 
wish to assign the same bell 
schedule.  

• Click Options again. 

• Select Mass Update. The Mass 
Update popup window will appear.  

• Choose Schedule Bell as the Field 
value.  

• Use the icon to select the 
appropriate bell schedule for these 
dates.  

• Click Update.  

• Acknowledge the confirmations. A 

School Setup 
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pop-up window will appear verifying 
the changes. 

• Click OK 

• Go to the icon and choose All 
Records to return to the full list of 
dates. You will now see the Bell > 
Name populated for those you 
mass updated, as well as the dates 
still to be done.  

• Repeat the steps above until all 
dates in your calendar have the 
appropriate bell schedule assigned. 

Option 2: Change date individually: 

• Click Options >  
Modify List. Pencils will appear in 
your column headers. 

• Click the ‘Pencil’ icon in the Bell > 
Name field. Pick list boxes will 
appear in the  
column.  

• Use the ‘Magnifying Glass’ icon to 
select the appropriate bell schedule 
for each date. 

• When finished, click the ‘Green 
Checkmark’ icon to save your 
entries.  

• Click Options > Modify List to 
return the list to the normal setting. 

School 
Calendar 
Setup 

School View > School 
TT > Calendars > 
Details 

Once the district calendar has been 
initialized, schools should see Details. 
Verify and update the required number 
of in-session days and School Year 
Context > Year ID and click Save. 
Schools need to re-assign schedule 
days and modify session dates as 
necessary to reflect school-specific 
session or non-session dates. 

School Setup 

Modify 
School 
Calendar 

School View > School 
TT > Calendars 

• Check the box beside the school 
year calendar you are preparing. 

• Click the Dates leaf on the 
Calendars side-tab. School dates 
should be populated. 

• Click the blue hyperlink beside the 
date you need to modify and make 
the necessary adjustments. 

a. Is school in session: check this box 
if attendance should be taken on this 
date. Uncheck this box if attendance 
will not be taken on this date. 
b. Schedule day number: type the 
Schedule day number. Example: if you 
are on a 2-day schedule, is this date 
supposed to be Day 1 or Day 2? 

School Setup 
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c. Schedule day type: populate this 
value from the drop-down menu, only if 
school is not in session on this date. 
d. Schedule Bell > Name: If your 
school uses a bell schedule, click the 
magnifying glass to select the 
appropriate bell schedule for this date. 

• Click Save. 

Review 
School 
Structure 

School view > Schedule 
top tab > Structure side 
tab. 

• Terms 

o Do all terms have dates? 

o Are all term dates inside the 
active schedule dates? 

o Are grade term cover maps set 
for all schedule terms? 

• Days 

o Are all days represented? 

• Periods 

o Are all periods in place and 
consecutive? 

• Bell Schedules 
Are all necessary bell schedules created? 

School Setup 

Setup Grade 
Terms 
(Task for VP/ 
Admin) 

School view > Grades 
top tab > Grade Terms 
side tab 

Grade terms are attached to schedule 
terms so must be defined before 
schedule terms can be set up. 

• Does the number of grade terms 
match the transcript definitions 
applied to courses? 

• Are the grade term dates inside the 
active schedule dates? 

To add grade terms: 

• Click Options > Add 

• Click the ‘Magnifying glass’ icon 
on the Term ID field and use the 
radio button to select the 
appropriate grade term definition, 
from the Grade Term Pick List 
pop-up window. 

• Use the ‘Calendar’ icon to select 
the start and end date of the 
grade term at your school. 

• Add grade terms for each of the 
date’s report cards are issued at 
your school. 

• Click Save 

• Repeat steps for each grade term 

• School Setup 

• Grade 
Management 
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required in the school. 

Setup Grade 
Term Cover 
Maps 
(Task for 
VP/Admin) 

School view > Schedule 
top tab > Structure side 
tab > Terms 

• Set appropriate grade term cover 
map boxes for all schedule terms. 

 
NOTE: You must SAVE each schedule 
term even if no adjustments are made 

• School Setup 

• Grade 
Management 

Review 
Course 
Catalogue 

School View > Schedule 
TT > Courses ST 

Filter for current year and review 
course attributes that impact mark 
entry: Transcript definition, Rubric 
Definition, Hide from Grade Input, Hide 
on Report Card 

School Setup 

Review 
Rooms 

School View > Schedule 
> Rooms 

Review the rooms  School Setup 

Review 
Schedule 
settings 

School view > School 
top tab > Setup side tab 
> Preferences leaf 

Category = Schedule School Setup 

Assigning 
Schedule 
Days to your 
Calendar 

School View > School 
TT > Calendars ST 

• Check the box beside the School 
Year > Year ID you are working 
with.  

• Select the appropriate calendar and 
click Dates. 

• On the Options > Reassign 
Schedule Days. 

• In the Start Date field, use the to 
select the start date. 

• In the End Date field, use the to 
select the end date.  

• Select the Initial Schedule Day 
you want to start with on the start 
date and click OK. 

School Setup 

Review 
student 
schedules 

School View > Student 
TT > Schedule ST 

Check matrix view to ensure it is 
populated and student courses are 
displayed correctly in the grid 

Student 
Scheduling 

Verify Student 
Demographics 

School View > Student 
TT > Details 

• Ensure Demographics are filled in.  

• Ensure every student has Calendar, 
Citizenship Code, Proof of Age, 
Home Language, Correct Address, 
Home Phone number, Correct 
Contacts 

• Review parent/guardian contact 
records for all students, especially all 
incoming grade 8s as well as any new 
students, to ensure that all 
appropriate tick boxes are checked. 
For MyClass Access, legal 
parent/guardians must have the 
“Contact has family portal access” 
box ticked. 

 

Enrollment and 
Demographics 

Verify and 
update locker 

School view > Lockers 
ST 

Add/remove/modify locker information as 
necessary 

School Setup 
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information 

 
 
Review 
student 
information 

 
 
School view > Student 
top tab 

 

• Are there any students with Pre-Reg 
or status other than Active that need 
changing? 

• Ensure calendars are assigned to all 
students. 

• Update homeroom as necessary. 

• Are all students in the appropriate 
grade?  If not, then you will need to 
change the YOG (Year of Grad) to 
reflect the appropriate grade 
If you need to change YOG  
• Student Top Tab > Select the 

student  
• Options > Registration > 

Promote/Demote Student 

• Do you have any Homeschooler’s 
registered with your school?  If so, 
their GrSubLvl (Grade Sub Level) 
needs to read HS.  Add an inclusion 
to the student’s PSR if you have a 
student who is homeschooling.  
Please advise Serena or Madhav of 
any Home schoolers. 
Are any students that were previously 
homeschooled and registered with 
your school (or otherwise) now 
attending your school as a regular 
student?  If so, remove the Grade 
Sub Level of HS 

• Do you have any International 
students registered with your school? 
If so, their GrSubLvl (Grade Sub 
Level) needs to read SU. The Grade 
Sub Level may be removed just prior 
to first TRAX submission (mid-
October). 

• Update family courier information 
as necessary. 

• Update Diploma Types. 

• Update Diploma Granted Date for 
students who completed courses over 
the summer to fulfill grad 
requirements. 

 
 
Enrollment and 
Demographics 

Review 
Student 
Enrollment 

School TT > Student ST  

Ensure there are no students with a 
Pre-Reg Enrollment Status 

• Student Top Tab > Filter  - 
PreReg Students 

Do your Enrollment numbers match 
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the Current Members (bums in seats) 

Filter ? 

• If not, compare the data in the filter 
with your own information 

Does the Current Members Filter 
match the All Active Students (active 

anywhere in BC) Filter ? 

• If not, compare the data from the two 
filters 

Current Members and All Active 
Students should match. 
Once you find the student(s) in question, 
check their Membership details 

• Student Top Tab > Membership 
Side Tab 

Correct as necessary. 
If you need to change a student’s 
Enrollment Status 

• Student Top Tab > Select the 
student. 

• Options > Registration > Change 
Student Status 

 

Adding 
Students into 
Programs 

 

Ensure that you have students added 
to correct 1701 fundable programs. 

• Do you have new AbEd students?  
Advise Admin Secretary for Aboriginal 
Education Department and she will 
add Program 

• Grade 8s will need to have the “Core 
French”, code #11002 program added 

• For French Immersion schools, 
ensure those participating in these 
programs have the FI program, not 
Core French. 

• ELL programs must be updated as 
per your conversation with your ELL 
teacher.  The Learning Services 
department will manage any 
Exceptional English Language 
Learner programs. 

• If you register any new students from 
out of district that indicate on their 
registration forms that the student has 
been designated at their previous 
district, please ensure your 
Admin/Support department is aware 
and correct forms are completed. 
Learning Services will enter programs 
for these students. 

If you have new students to the school 
and they have open programs from 
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their previous school, please click into 
the prior programs and end date them 
with the date the student left the 
previous school. 
 

Students with 
secondary 
school 
associations 

School view > Student 
TT 

Do all secondary students have their 
attendance management type set 
appropriately? 
Filter = Cross Enrolled FROM this 
school; 
Filter = All Secondary Students; 

Enrollment and 
Demographics 

Review fee 
assignments 

School view > School 
top tab > Cashier’s 
Office side tab > Fees 
sub-side tab. 

Delete or void any outstanding fees for 
students who have left your school. 

Fees 
Management 

Validate Staff 
Records 

School view > Staff top 
tab 

• Review staff roster and submit IT 
WebHelp Desk ticket for changes. 

• Update staff homeroom assignments 
as necessary 

Security 
Management 

Staff Changes 
 

 

If the school staff has changed DO NOT 
make any additions or deletions to the 
staff records in MyEdBC and do not 
make them inactive.  Staff must be 
assigned to schools from the DEO.  Submit 
an IT Web HelpDesk ticket with full name of 
Teacher and FTE. 
 

 

Assigning 
Homerooms 
to Teachers 

School View > Staff TT  

Options > Modify list and click on the 

pencil  in the Homeroom column (don’t 

forget to click on the  to save the 
changes to the column 
Alternatively, Staff TT > Select Staff > 
Details. 
 

 

Assigning 
Homerooms 
to Students 

School View > Students 
TT 

Option 1: Assigning a homeroom to an 
individual student: 

• Check the box beside the student name 
and click the Details side tab, or click 
the blue link of the student name. 

• In the Homeroom field on the 
Demographics sub-top tab, enter the 
homeroom assigned to the student. 

• Click Save. 
Option 2: Modify individual student 
records in a list 

• Click Options in the menu bar. 

• Select Modify List. 

• Click the ‘Pencil’ icon in the Homeroom 
field. 

• Enter the homeroom value for each 
student in the list.  

 

https://www.sd42.ca/helpdesk/helpdesk-create-ticket/
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• Click the ‘Green Check’ icon to save the 
entries.  

• Click Options in the menu bar and 
select Modify List to shut the function 
off. 

Option 3: Mass Update 

• Place a check in the box beside each 
name to be assigned to the same 
homeroom.  

• Click Options in the menu bar.  

• Select Show Selected. The list of 
students selected appears for 
confirmation.  

• Click Options in the menu bar.  

• Select Mass Update 

• In the Mass Update pop-up window, set 
the Field value to Homeroom using the 
dropdown menu.  

• In the Value field, type the homeroom 
number to be assigned to all the 
selected students.  

• Click Update. Accept the confirmations.  

• A Mass-Updated validation window will 
pop up. Click OK. 

 
 

Transferring Students to new Schools 
If there are students that are transferring to new schools in district prior to the first day of 
school, follow the transfer process.  The incoming school must set the withdraw reason from 
the previous school to either no show if they didn’t attend at all, or Public School/In District.  
This will ensure the membership record is correct. 

 

If there are students that are leaving the school for an out of district school prior to the first 
day of the school year, then withdraw the student with an appropriate reason (either no 
show or Public School/Out of District).  This will ensure the membership record is correct. 

 


