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PLEASE NOTE: 
Admin tasks are set with a ‘*’ and highlighted 
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2.0 School Tasks 
 

 
Task Path Description Relevant Document(s) for Detail 

□ Review Attendance 
Settings 

• School view > School top 
tab > Setup side tab > 
Preferences leaf 

• Category = Daily Attendance 

• Category = Class Attendance 

• Category = Secondary School 
Management 

• School Setup 

• Class Attendance Management 

• Daily Attendance Management 

□ Review Schedule settings • School view > School top 
tab > Setup side tab > 
Preferences leaf 

• Category = Schedule • School Setup 

□ Continuous Entry schools 
confirm Active Date 
Enabled By setting 

• School view > School top 
tab > Setup side tab > 
Preferences leaf 

• Category = Grade • DL and CE School Setup and 
Processes 

□ * Commit schedule in 
build   view 

• Build View • Choose Scenario to be used as 
the master schedule for the year. 

• Review Master Schedule in 
School view (Section details) 

• School Setup 

 
 
 
 
 
 
 
 
 
 
 
 

 

* Task for VP/Admin 

In Build View, Set the dates 
of the terms: 

Scenarios TT >Terms ST 
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Task Path Description Relevant Document(s) for Detail 

□ * Set active schedule 

 
* Task for VP/Admin 

 

• School View > School top 
tab > Schedules side tab. 

 
If a schedule was committed 
from the Build view, this will be 
in place. 

 
If creating schedules manually, 
an active schedule will need to 
be created. 

• Is the schedule Active? 

• Do the dates cover the entire 
school calendar? 

• School Setup 

□ * Set up grade terms 

 
* Task for VP/Admin 

 

• School view > Grades top 
tab > Grade Terms side tab. 

• Does the number of grade terms 
match the transcript definitions 
applied to courses? 

• Are the grade term dates inside 
the active schedule dates? 

• School Setup 

• Grade Management 

□ * Set Grade Term 
Cover Maps 

 
* Task for VP/Admin 

 

• School view > Schedule top 
tab > Structure side tab > 
Terms 

• Set appropriate grade term cover 
map boxes for all schedule terms 

 
NOTE: You must SAVE each 
schedule term even if no adjustments 
are made 

• School Setup 

• Grade Management 
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Task Path Description Relevant Document(s) for Detail 

□ Review Course 
Catalogue 

• School view > Schedule top 
tab > Courses side tab. 

• Course attributes 

o Transcript Definitions. 

o Rubric Definitions 

o Attributes in the Report Card 
Field Set. 

 

• School Setup 

□ Review Structure • School view > Schedule top 
tab > Structure side tab. 

• Terms 

o Do all terms have dates? 

o Are all term dates inside the 
active schedule dates? 

o Are grade term cover maps 
set for all schedule terms? 

• Days 

o Are all days represented? 

• Periods 

o Are all periods in place and 
consecutive? 

• Bell Schedules 

o Are all necessary bell 
schedules created? 

• School Setup 

□ Review student 
schedules 

• Student top tab > Schedule 
side tab 

• Check matrix view to ensure it is 
populated and student courses 
are displayed correctly in the grid. 

• Student Scheduling 
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Task Path Description Relevant Document(s) for Detail 

□ Review school calendar • School view > School top 
tab > Calendars side tab. 

• Adjust non-session dates as 
necessary. 

• Assign Day numbers to each in- 
session date as appropriate. 

• Assign Bell Schedules to each in- 
session date as appropriate 

• School Setup 

□ Review school locker 
table 

• School view > Lockers side 
tab. 

• Add/remove/modify locker 
information as necessary. 

• School Setup 

□ Review student locker 
assignments 

• School view > Student top 
tab. 

• Add/remove/modify locker 
information as necessary. 

• Enrollment and Demographics 

□ Review fee assignments • School view > School top 
tab > Cashier’s Office side 
tab > Fees sub-side tab. 

• Delete or void any outstanding 
fees for students who have left 
your school. 

• Fees Management 
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Task Path Description Relevant Document(s) for Detail 

□ Review student 
information 

• School view > Student top 
tab 

• Are there any students with Pre-Reg 
or status other than Active that need 
changing? 

• Ensure calendars are assigned to all 
students. 

• Update homerooms as necessary. 

• Do students YOGs match their 
grades? 

• Review students with grade sub- 
levels of HS, SU. Is this still 
appropriate? 

• Update family courier information as 
necessary. 

• Update Diploma Types. 

• Update Diploma Granted Date for 
students who completed courses 
over the summer to fulfill grad 
requirements. 

• Enrollment and Demographics 

□ Students with secondary 
school associations 

• School view > Student top 
tab 

• Do all secondary students have 
their attendance management 
type set appropriately? 

• Enrollment and Demographics 

□ Validate Staff Records • School view > Staff top tab. • Review staff roster and submit IT 
WebHelp Desk ticket for changes 

• Update staff homeroom 
assignments as necessary. 

 

• Security Management 
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Staff Information 
Review Staff information 

Staff Changes 
If the school staff has changed DO NOT make any additions or deletions to the staff records in MyEdBC and do 
not make them inactive.  Staff must be assigned to schools from the DEO.  Submit an IT Web HelpDesk ticket 
with full name of Teacher and FTE. 
 

Assigning Homerooms 
Now that EOYR has completed, you can now change teacher divisions, if they’ve changed from last year.  If they 
haven’t, they’ll have rolled over as they were from last year. 

 
Staff Top Tab 

o Options > Modify list and click on the pencil  in the Homeroom column (don’t forget to click on the  
to save the changes to the column 

o Alternatively,  Staff Top Tab > Select Staff > Details  
 

 
 

 
Counsellors & Support teaching staff 

Please send a list of the school’s teaching staff that are Support teachers and the school counsellor via email to 
myedhelpdesk@sd42.ca as these positions require different security roles.  

  

https://www.sd42.ca/helpdesk/helpdesk-create-ticket/
mailto:myedhelpdesk@sd42.ca
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Adding Students into Programs 
Ensure that you have students added to correct 1701 fundable programs. 

• Do you have new AbEd students?  Advise Admin Secretary for Aboriginal Education Department and she will 
add Program 

• Grade 8s will need to have the “Core French”, code #11002 program added 

• For French Immersion schools, ensure those participating in these programs have the FI program, not Core 
French. 

• ELL programs must be updated as per your conversation with your ELL teacher.  The Learning Services 
department will manage any Exceptional English Language Learner programs. 

• If you register any new students from out of district that indicate on their registration forms that the student 
has been designated at their previous district, please ensure your Admin/Support department is aware and 
correct forms are completed. Learning Services will enter programs for these students. 

 
If you have new students to the school and they have open programs from their previous school, please click into the prior 
programs and end date them with the date the student left the previous school. 
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School Details 
Review School details  

Did the administration change? 
School Top Tab > Setup Side Tab   

o Click Details 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

o On Top Right corner, choose All fields as dropdown. Scroll to bottom and ensure Principal Email is correct.  
 

 
Ensure you make any admin/school detail changes on the Province’s Schools and Districts Contact Information site. 

  

http://www.bced.gov.bc.ca/apps/imcl/imclWeb/Home.do
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School Calendar 
 Review School Calendar 

School Top Tab > Calendars Side Tab > Dates Sub Side Tab 
o Adjust non-session dates as necessary  
o If not already done, assign Day Numbers to each school day in session: 

o Use the Filter   Days In Session to display school days 
o Options > Modify List 

 
 
 
 
 
 
  

o Click Update 

Student Information 
 Review Student Enrollment 

Ensure there are no students with a Pre-Reg Enrollment Status 

o Student Top Tab > Filter  - PreReg Students 

Do your Enrollment numbers match the Current Members (bums in seats) Filter ? 
o If not, compare the data in the filter with your own information 

Does the Current Members Filter match the All Active Students (active anywhere in BC) Filter ? 
o If not, compare the data from the two filters 

 
Current Members and All Active Students should match 

 
Once you find the student(s) in question, check their Membership details 

o Student Top Tab > Membership Side Tab 
o Correct as necessary 
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If you need to change a student’s Enrollment Status 
o Student Top Tab > Select the student 
o Options > Registration > Change Student Status 

 
Review parent/guardian contact records for all students, especially all incoming grade 8s as well as any new students, 
to ensure that all appropriate tick boxes are checked. For MyClass Access, legal parent/guardians must have the 
“Contact has family portal access” box ticked. 

 
 

YOG 
Are all students in the appropriate grade?  If not, then you will need to change the YOG (Year of Grad) to reflect the 
appropriate grade 
 
If you need to change YOG  

o Student Top Tab > Select the student  
o Options > Registration > Promote/Demote Student 

 
Homeschooler 

Do you have any Homeschooler’s registered with your school?  If so, their GrSubLvl (Grade Sub Level) needs to read 
HS.  Add an inclusion to the student’s PSR if you have a student who is homeschooling.  Please advise Natalie or 
Serena of any Home schoolers. 
 
Are any students that were previously homeschooled and registered with your school (or otherwise) now attending 
your school as a regular student?  If so, remove the Grade Sub Level of HS 

 

International Students 
Do you have any International students registered with your school? If so, their GrSubLvl (Grade Sub Level) needs to 
read SU. The Grade Sub Level may be removed just prior to first TRAX submission (mid-October). 
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Photographer Export 
You will likely have your student photo date already arranged for some time early in September or October. Ensure that 
you do not provide the photographer with any more student information than they need.  Follow these steps to easily 
extract the information they need: 
• Student Top Tab > Filter  - Current Members > Field Set   - Photographer 
• Using the quick print option  , choose CSV 
• Once the operation has run, open the CSV, rename it and save it to OneDrive 

•         Follow this process to share the document to the Photographer: 
 
 

To password protect a folder or document to be shared with external users, click on the OneDrive (Blue Cloud) icon in 
your task bar and then choose View online 

 
Select the file or folder you want to share and then click on the Share icon  

 
Choose Anyone with the link option and then set a unique password (not one you currently use for anything else).  You 
can also specify when access to the file or folder will stop 
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Transferring Students to new Schools 
If there are students that are transferring to new schools in district prior to the first day of school, follow the transfer 
process.  The incoming school must set the withdraw reason from the previous school to either no show if they didn’t attend 
at all, or Public School/In District.  This will ensure the membership record is correct. 

 

If there are students that are leaving the school for an out of district school prior to the first day of the school year, then 
withdraw the student with an appropriate reason (either no show or Public School/Out of District).  This will ensure the 
membership record is correct. 


